BunBackupとは？

←→
  BunBackupとは？

BunBackupは簡単高速に大事なファイルをバックアップするためのソフトです
BunBackupは、Windows2000/XP/Vistaで動作するフリーソフトです

最低限バックアップしたいフォルダとバックアップ先フォルダを選択するだけで、新しいファイル、更新されたファイルだけをコピーすることができます

必要があれば、対象ファイルや除外ファイルの指定や、バックアップの条件(新しいファイル、新しい時刻、異なるサイズ、すべて上書きコピー)なども指定することができます。

設定を簡単にしたいため、できるだけシンプルな入力にしています
バックアップは、パソコンに詳しい人にだけでなく誰にでも必要です
一度でもHDDが壊れたり、間違ってファイルを削除・変更してしまった経験のある方であれば、バックアップの重要性を理解していると思います
ただ、このようなことはよく起こることではないので、バックアップが面倒で、ついついバックアップをとらずに過ごしてしまい、大事なファイルを無くしてしまいます

アプリケーション自体は、HDDが壊れてもインストールしなおせば元に戻すことができますが、自分で作成したデータは元に戻すことができません
BunBackupを利用して、大事なファイルをバックアップし、少しでも皆さんのお役に立てればと思います


  インストール

インストーラーが付属している場合

インストーラーが付属している場合は、インストーラーを起動して、画面の指示に従ってBunBackupをインストールしてください

インストーラーが付属していない場合

下記の手順でインストールしてください

    1. 「BunBackup.lzh」をダウンロード
    2. 「BunBackup.lzh」を解凍
    3. BunBackup用フォルダを作成
    4. 解凍したファイルを作成したフォルダにコピー

圧縮バックアップする場合

BunBackupで「圧縮」機能を使用する場合は、使用する圧縮形式によりDLLが必要になります
（「圧縮」機能を使用しない場合は下記のDLLはインストールする必要はありません）

LZH形式の場合は「UNLHA32.DLL」、ZIP形式の場合は「UNZIP32.DLL」「ZIP32J.DLL」「ZIP32.DLL」が必要になります
これらのDLLは下記のホームページよりダウンロードしてください

▼統合アーカイバ
http://www.csdinc.co.jp/archiver/
各DLLのインストール方法は、それぞれのDLLのマニュアルなどをご参照ください
なお、DLLによって使用条件が異なります
各DLLをご使用になる場合は、必ず各DLLの使用条件をご確認ください


  アンインストール

インストーラー付きのファイルからインストールした場合は、Windowsの「プログラムの追加と削除」からアンインストールすることができます

インストーラーが付いていないファイルからインストールした場合は、下記の手順でアンインストールしてください

  1. BunBackupをインストールしたフォルダにあるすべてのファイルを削除してください
  2. BunBackupの設定ファイル(*.lbk)を削除してください

レジストリ

BunBackupは初期設定ではレジストリを使用しませんが、「設定」メニューの「環境設定」で「レジストリを使用する」をチェックした場合は、BunBackupの情報をレジストリに保存します
レジストリを使用していてレジストリキーの削除が必要があれば下記のレジストリの項目も削除してください
HKEY_CURRENT_USER\Software\Bun\BunBackup
レジストリは、間違って変更・削除してしまいますと、Windowsやほかのアプリケーションに、致命的な影響を与えてしまいますので、十分注意して削除してください

BunBackupユーティリティーを使用すると、レジストリを安全に削除する機能があります

▼BunBackupユーティリティー
 http://homepage3.nifty.com/nagatsuki/bunbackup/utility/utility.htm


  機能の選択

BunBackupでは、誰でも簡単にバックアップできることを目的としているため、最初は必要最低限の機能しか設定できないようになっています
それ以外の機能については、「機能表示設定」で必要な機能をチェックすることで使用できるようになります

そのため、いろいろな機能を使ってみたい場合は、BunBackupを使い始める前に「機能表示設定」で必要な機能を選択してください
ここでチェックした機能の設定項目が、「バックアップ設定」「バックアップ詳細設定」「環境設定」などに現れます

「機能表示設定」は、設定を表示するかしないかを選択するだけで、その機能を使用するかしないかを選択するものではありません
そのため、ここでチェックするだけでは機能は働きません
必ず、


  主な機能

バックアップ元フォルダ・バックアップ先フォルダの指定

最低限バックアップしたいフォルダとバックアップ先フォルダを選択するだけで、新しいファイル、更新されたファイルをコピーすることができます

対象・除外ファイルの指定

対象ファイルを指定すると、指定されたファイルのみをバックアップの対象とします
除外ファイルを指定すると、指定されたファイルをバックアップの対象から除外します
何も設定していない場合は、すべてのファイルをバックアップの対象とします

バックアップの条件の指定

新しいファイル・新しい時刻・異なるサイズ・すべて上書きコピー、などを指定できます

コピーファイルのプレビュー表示

実際にコピーする前に、コピーするファイルをあらかじめチェックできるプレビュー機能があります
プレビューでコピー不要なファイルがある場合は、コピーファイル一覧から削除することができます

自動バックアップ

ソフト単体で一定間隔ごと、指定時刻などの自動バックアップができます
Windowsのタスクを利用した自動バックアップも可能です

世代管理

ファイルの変更履歴を世代管理用フォルダに保存していくことができます

高速ファイルチェック

バックアップの場合、ファイルのコピーに時間がかかるのは当然ですが、バックアップ元・先フォルダにあるファイルの情報の収集にも時間がかかります
「高速ファイルチェック」は、バックアップ先のファイル情報をキャッシュすることで、高速なバックアップが可能にしています

ログの記録

バックアップの結果をファイルに記録します
記録したログは後から表示させることができます

ミラーリング

バックアップ元のファイルが削除されている場合、バックアップ先のそのファイルを削除します
なお、バックアップ元ファイル保護のため、バックアップ先のファイルが削除されていても、バックアップ元のファイルは削除されない安全設計になっています

除外フォルダ

一時フォルダやワークフォルダのようにバックアップが必要ないフォルダを除外することができます
除外フォルダを指定すると、指定したフォルダ名が見つかった場合、そのフォルダのファイル、及びそのフォルダのサブフォルダのファイルはコピー対象から外されます

上書き時に警告

この機能を使用すると、バックアップ先にコピーするファイルと同名のものがある場合、上書きしていいかの確認のダイアログを表示します


  バックアップ手順

1.BunBackupを起動する

2.ツールバーの[追加]ボタンをクリックする

3.「タイトル」を入力する

タイトルは何を入力してもかまいません
後から見てわかりやすいタイトルをつけてください

4.「バックアップ元フォルダ」を入力する

バックアップしたファイルがあるフォルダを設定してください
入力する部分の右側にあるボタンをクリックすると、フォルダの一覧を表示しますので、その中からフォルダを選択することができます

5.「バックアップ先フォルダ」を入力する

ファイルをコピーしておくフォルダを設定してください
入力方法は「バックアップ元フォルダ」と同様です
「バックアップ先フォルダ」が存在しない場合は、自動的に作成されます

6.[OK]ボタンをクリックしてください

これで、[バックアップ開始]ボタンをクリックすると、バックアップ元フォルダとバックアップ先フォルダにあるファイルを比較し、新しいファイル・変更があったファイルをバックアップ先フォルダにコピーします
サブフォルダがある場合は、サブフォルダも同様にコピーします
さらに詳細な設定につきましては、「リファレンス」を参照してください


  画面構成

画面構成は、「表示」メニューの設定によって異なります

基本画面

インストール後の基本的な画面は以下のようになります
バックアップリストでドラグ＆ドロップすると、バックアップ設定の順番を入れ替えることができます
また、Ctrl+↑、Ctrl+↓でも順番を入れ替えることができます
ツールバーのアイコンの大きさは、「表示」メニューの「ツールバー」で変更することができます

ファイル選択リスト

「表示」メニューで「ファイル選択リスト」をチェックした場合は以下のようになります
ファイル選択リストでドラグ＆ドロップすると、リストの順番を入れ替えることができます

選択バックアップ＋チェックボックス

「機能表示設定」で「選択バックアップ」をチェックし、「表示」メニューで「チェックボックス」をチェックした場合は以下のようになります


  機能の制限事項

BunBackupは、機能の組み合わせについて下記のような制限事項があります

全体

  • Windows95/98/Meでは動作しない

コピーできないファイル

  • 別のプロセスで読み込みがロックされているファイル
  • フルパス名が260文字(半角)をこえるファイル

圧縮

  • 「圧縮」を使用した場合、「高速ファイルチェック」は使用できない
  • 「圧縮」を使用した場合、「世代管理」は使用できない
  • ZIP形式で圧縮時、ミラーリングで削除できないファイル名がある（ZIP関係のDLL側の問題）
  • Unicodeのファイル名は圧縮バックアップできない

高速ファイルチェック

  • 「高速ファイルチェック」を使用した場合は、フォルダのミラーリングは行われない
  • 「高速ファイルチェック」を使用した場合は、空フォルダのバックアップは行われない

プレビュー

  • プレビュー時、空フォルダのバックアップ、フォルダのミラーリングは表示されない

バックアップ結果・ログ表示

  • 空フォルダのバックアップ、空フォルダのミラーリングの結果は表示されない

対象・除外ファイル、除外フォルダのワイルドカード

  • 対象・除外ファイルや除外フォルダでワイルドカードを使用するとき、先頭にワイルドカードを使用し、かつその後が2バイト文字の場合は、正しく抽出されない場合がある（例： 「*漢字*.*」）

暗号化

  • ファイルの概要プロパティをコピーすると、復号化しても元のファイルと完全に一致しない場合がある（概要プロパティ部が変化するためで、ファイルの内容自体は一致する）
  • 暗号化バックアップ時に「エラーファイル」があった場合、エラー原因が正しく表示されないことがある

Unicode

  • BunBackup.exeをUnicodeが含まれるパス名のフォルダに保存できない
  • 設定ファイル(拡張子が.lbkのファイル)をUnicodeが含まれるパス名のフォルダに保存できない
  • 世代管理の「フォルダフォーマット」にUnicodeを含んではいけない
  • 一部のエラーメッセージはUnicodeが文字化けする


  新規作成

現在設定されている項目をすべて初期値に戻します

変更されている項目がある場合は、「ファイルの変更を保存しますか?」という確認のウインドウを表示します
[はい]ボタンをクリックすると、新規作成する前に現在の設定をファイルに保存することができます


  開く

以前作成したBunBackup用の設定ファイルを開きます
BunBackup用の設定ファイルは、拡張子が「.lbk」のファイルです。

変更されている項目がある場合は、「ファイルの変更を保存しますか?」という確認のウインドウを表示します
[はい]ボタンをクリックすると、開く前に現在の設定をファイルに保存することができます


  上書き保存

設定した項目をファイルに保存します
まだファイル名が設定されていない場合は、ファイル名を入力するウインドウを表示しますので、ファイル名を設定してください


  名前を付けて保存

ファイル名を設定して、項目を保存します


  終了

BunBackupを終了します

項目が変更されていて、まだファイルに保存していない場合は、「ファイルの変更を保存しますか?」という確認のウインドウを表示します
[はい]ボタンをクリックすると、終了する前に現在の設定をファイルに保存することができます


  追加

「バックアップ設定」を参照してください


  サブフォルダもバックアップする

この項目をチェックすると、「バックアップ元フォルダ」で設定されたフォルダにサブフォルダがあった場合は、サブフォルダ以下のすべてのファイルをバックアップの対象とします

この項目をチェックしない場合は、「バックアップ元フォルダ」にあるファイルのみをバックアップの対象とします


  バックアップ方法

■条件指定

指定された条件の時にバックアップします
新しいファイル
バックアップ先フォルダに存在しないファイルがある場合にバックアップします
新しい時刻
バックアップ元フォルダとバックアップ先フォルダのファイルの日付を比較して、バックアップ元フォルダの方が新しければバックアップします
異なるサイズ
バックアップ元フォルダとバックアップ先フォルダのファイルのサイズを比較して、サイズが異なればバックアップします

■常にコピー

バックアップ元フォルダにあるファイルは、条件にかかわらず、すべてバックアップします

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「バックアップ方法」タブをクリックします


  ミラーリング

バックアップ元で削除されたファイルがあるとき、バックアップ先のそのファイルを削除します
BunBackupはバックアップを目的としているため、ミラーリングで削除されるのは、バックアップ先にあるファイルだけです
バックアップ元のファイルが削除されることはありません

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「バックアップ方法」タブをクリックします
この中に、「ミラーリングする」という設定項目があります

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ミラーリング」をチェックしてください
「機能表示設定」でチェックしないと「ミラーリング」の設定項目が表示されません


  対象ファイル

対象ファイルを指定すると、指定されたファイルのみをバックアップの対象とします
何も設定していない場合は、すべてのファイルをバックアップの対象とします
ファイルは、ファイルを個別に設定することもできますし、ワイルドカードを使用することもできます（例　*.lbk）

■追加

対象ファイルを追加します
ファイル名には、ワイルドカード（*、?）を使用することができます
（例 拡張子がjpgのファイルを指定する場合は「*.jpg」、ファイルの先頭が「Data」で始まるファイルの場合は「Data*.*」）

ファイル名は、手入力することもできますし、入力の履歴から選択することもできますし、ファイル一覧から選択することもできます
手入力
直接ファイル名を入力してください
手入力の場合は、ファイル名を一度に複数入力することもできます
一度に複数入力する場合は、ファイル名を「;」（セミコロン）で区切ってください
入力履歴
入力履歴から選択する場合は、▼ボタンをクリックして一覧を表示して選択してください
入力履歴からの削除
入力履歴から削除したい項目がある場合は、その項目を「ファイル名」に入力してCTRLキーを押しながらDELキーを押してください
ファイル一覧
ファイル一覧から選択する場合は、[･･･]ボタンをクリックしてくださいファイルを選択できるウインドウを表示しますので、対象としたいファイルを選択してください
このウインドウでは、必要があれば複数のファイルを一度に選択することができます
複数のファイルを選択する場合は、CTRLキーを押しながらファイルをクリックするか、先頭のファイルをクリックしてから終わりのファイルをShiftキーを押しながらクリックします

■追加（拡張子選択）

バックアップ元フォルダにあるファイルの拡張子一覧から対象ファイルを追加することができます
「バックアップ設定」で「バックアップ元フォルダ」にある拡張子の一覧を表示します
また「バックアップ詳細設定」で「サブフォルダもバックアップする」がチェックされている場合は、サブフォルダの拡張子一覧も表示します
ダイアログ左側にある「拡張子一覧」から、対象ファイルに追加したい拡張子を選択して、「>」（追加ボタン）をクリックしてください
「拡張子一覧」から複数に選択することができます
複数選択する場合は、CTRLキーを押しながらクリックするか、先頭をクリックしてから終わりをSHIFTキーを押しながらクリックしてください

■削除

対象ファイルの一覧から削除します

■編集

対象ファイルを編集します


  除外ファイル

バックアップから除外するファイルを指定します
何も設定していない場合は、すべてのファイルをバックアップの対象とします
ファイルは、ファイルを個別に設定することもできますし、ワイルドカードを使用することもできます（例　*.lbk）

■追加・削除・編集

「対象ファイル」と同様に設定してください


  ボリュームラベル

バックアップする前にバックアップ先ドライブのボリュームラベルをチェックし、設定されたラベルと異なる場合は警告を表示し、バックアップを中断します

■バックアップ先ドライブのボリュームラベルをチェックする

バックアップ時にバックアップ先ドライブのボリュームラベルをチェックしたい場合にチェックします

■ボリュームラベル

バックアップ先のボリュームラベルを入力します
「ボリュームラベル取得」ボタン
バックアップ先ドライブにバックアップするメディアを挿入してからこのボタンをクリックしてください
ボタンをクリックするとドライブの一覧を表示しますので、バックアップ先ドライブを選択すると、そのメディアのボリュームラベルを取得します

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「ボリュームラベル」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ボリュームラベルチェック」をチェックしてください
「機能表示設定」でチェックしないと「ボリュームラベルチェック」の設定項目が表示されません


  ネットワークログイン

バックアップする前に設定されたユーザー名とパスワードでネットワークにログインします

■バックアップ先コンピュータにネットワークログインする

バックアップ先コンピュータにネットワークにログインする場合にチェックチェックします

■ユーザー名・パスワード

ネットワークにログインするための「ユーザー名」「パスワード」を入力します
「ユーザー名」と「パスワード」は、バックアップ先のネットワークによって設定方法が異なります
「ユーザー名」と「パスワード」を入力する場合は、あらかじめバックアップ先のネットワークについて調べてから入力してください

■バックアップ後ログオフする

バックアップ後にログオフしたい場合はこれをチェックしてください

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「ログイン」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ネットワークログイン」をチェックしてください
「機能表示設定」でチェックしないと「ネットワークログイン」の設定項目が表示されません

注意

この機能はバックアップ先コンピュータへのログインする機能です
バックアップ元コンピュータにはログインできません
バックアップ元コンピュータにログインが必要な場合は、ダミーの「バックアップ設定」を一つ追加し、「バックアップ先フォルダ」にログインしたいパソコンを指定してください
このとき「バックアップ元フォルダ」はローカルHDDなどに一つからのダミー用フォルダを作成してください


  上書き警告

バックアップ先にコピーするファイルと同名なファイルがあったときに、確認のダイアログを表示します
ファイルが更新されるはずがない場合や、バックアップ先に上書きしてしまっては困るファイルがある場合などに使用してください

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「ファイルチェック」タブをクリックします
この中に、「上書きする時に警告を出す」という設定項目があります

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「上書き時に警告」をチェックしてください
「機能表示設定」でチェックしないと「上書き時に警告」の設定項目が表示されません


  高速ファイルチェック

バックアップの場合、ファイルのコピーに時間がかかるのは当然ですが、バックアップ元・先フォルダにあるファイルの情報の収集にも時間がかかります
「高速ファイルチェック」は、バックアップ先のファイル情報をローカルHDDにキャッシュすることで、高速なバックアップが可能にしています

使用上の注意１

「高速ファイルチェック」はバックアップ時間を大幅に短縮できる可能性がある機能ですが、下記の説明をよくお読みになって、ご理解いただけない場合使用しないようにしてください
「高速ファイルチェック」はバックアップ先にあるファイル情報を直接取得するのではなく、ファイル情報をローカルHDDにキャッシュすることで、ファイルチェックの時間を短縮しています
そのため、バックアップ先のファイルをBunBackup以外で更新・削除・ファイルコピーなどを行った場合は、BunBackupに反映されませんので、注意してください
BunBackup以外のソフトなどで、バックアップ先のファイルを更新などした場合は、「設定」メニューにある「高速ファイルチェックDBの再構築」を実行してください

使用上の注意２

「高速ファイルチェック」は、かならずバックアップ時間を短縮できるわけではありません
バックアップ先のメディアのアクセス速度、ローカルHDDのアクセス速度、CPUパワーなど、バックアップ環境によって異なります
そのため、この機能を使う場合は、この機能を使用したときと使用しないときのプレビューまでの時間を測定することをおすすめします

制限事項

  • 高速ファイルチェックを使用時は、フォルダのミラーリングは行いません
  • 高速ファイルチェックを使用時は、空のフォルダはバックアップされません

高速ファイルチェックのちょっと変わった使い方

複数メディアに分割バックアップ
「高速ファイルチェック」機能を使用すると、バックアップ先のファイルが変わっていても、BunBackupにはわかりません
そのため、一つのメディアには収まりきらないたくさんのファイルがある場合、この機能を利用すると擬似的に、複数メディアに分割バックアップすることができます
複数メディア分割バックアップ方法
「高速ファイルチェック」をチェックします（使用する状態にする）
1枚目のメディアを用意してバックアップします。
1枚目のメディアがファイルでいっぱいになってしまうと、入りきらなかったファイルはエラーファイル一覧に表示されます
次に2枚目のメディアを用意して、1枚目と同様にバックアップします
すると、1枚目にコピーしたファイルはコピーされず、エラーファイルになったものだけコピーされます
これを、エラーファイルが表示されなくなるまで、次のメディアを用意してバックアップしていきます
これで、擬似的な複数メディア分割バックアップができます
注意
この方法は、本来の目的の使い方ではないため、「高速ファイルチェック」をよく理解できない場合は使用しないでください

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「ファイルチェック」タブをクリックします
この中に、「高速ファイルチェック」という設定項目があります

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「高速ファイルチェック」をチェックしてください
「機能表示設定」でチェックしないと「高速ファイルチェック」の設定項目が表示されません


  コピーエラー時バックアップ先ファイル保護

バックアップ先ファイルを常に保護するための機能です

ファイルコピー中何らかのトラブルでコピーが中断してしまった場合、すでにあるバックアップ先ファイルが上書きされる場合があります
上書きされた場合、バックアップ先ファイルは途中までしかコピーされません

このような状況を回避するために、「コピーエラー時バックアップ先ファイルを保護」を使用します
この機能は、すでにバックアップ先にコピーするファイルがある場合、そのファイルを上書きするのではなく、一時ファイル名でコピーし、コピーが成功するとその一時ファイルを元のファイル名にリネームします
何らかのトラブルでコピーが中断してしまった場合は、その一時ファイルを削除するだけなので、元のファイルに影響はありません
このようにすることで、コピー時のトラブルがあっても、常にバックアップ先のファイルが保護されます

コピーが中断する原因としては以下のようなことがあります

・バックアップ先（または元）との接続が不安定な場合

ネットワーク接続（無線LANなど）で通信が不安定な場合は、コピーが中断されることがあります

・バックアップ元ファイルの一部だけがロックされている

バックアップ元ファイルが通常のロック（読み込みがファイルごとロック）されている場合は、バックアップ先ファイルが上書きされる前にエラーとなるため、この機能を使用する必要はありません

注意

この機能を使用する場合は、下記の2点に注意してください
  • バックアップ先には、一時ファイルを作成する分の空き容量が必要
  • 一時ファイルのリネームなどの作業を行うため、通常のコピーよりも時間がかかる

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「ファイルチェック」タブをクリックします
この中に、「コピーエラー(または中断)時、バックアップ先ファイル保護」という設定項目があります

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「バックアップ先ファイル保護」をチェックしてください
「機能表示設定」でチェックしないと「バックアップ先ファイル保護」の設定項目が表示されません


  除外フォルダ

一時フォルダやワークフォルダのようにバックアップが必要ないフォルダを除外することができます
除外フォルダを指定すると、指定したフォルダ名が見つかった場合、そのフォルダのファイル、及びそのフォルダのサブフォルダのファイルはコピー対象から外されます

フォルダ名だけを指定した場合は指定されたフォルダ名すべてを除外しますが、フルパスで指定した場合はフルパスで指定された一つのフォルダだけを除外します
フォルダ名だけを指定する場合は、ワイルドカードも使用することができます（Temp*)

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「除外フォルダ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「除外フォルダ」をチェックしてください
「機能表示設定」でチェックしないと「除外フォルダ」の設定項目が表示されません


  世代管理

ファイルの変更履歴を、バックアップごとに世代管理用フォルダに保存していくことができます

■フォルダフォーマット

履歴を保存する世代管理用フォルダ名のフォーマットを「フォルダフォーマット」に設定してください
「y」はバックアップ時の年、「m」は月、「d」は日、「h」は時、「n」は分、「s」は秒を表します

「y」「m」「d」「h」「n」「s」以外の文字を世代管理フォルダに設定する場合は、「'」(シングルコーテーション)で囲んでください
（例：　「'世代' yyyymmdd」「'Backup' yy-mm」）

■保存期間

履歴ファイルを保管する日数を入力します
「0」を入力すると、履歴ファイルを削除されません

■世代管理をバックアップ先とは別のフォルダに保存する

これをチェックすると、世代管理ファイルをバックアップ先フォルダとは別の場所に保存することができます
通常、世代管理ファイルはバックアップ先フォルダに、「フォルダフォーマット」で設定された名称でサブフォルダを作成します
「世代管理をバックアップ先とは別のフォルダに保存する」をチェックすると、「世代管理を保存するフォルダ」に世代管理ファイルを保存します

■世代管理を保存するフォルダ

「世代管理をバックアップ先とは別のフォルダに保存する」をチェックした場合、世代管理ファイルを保存するフォルダを指定します
この場合、「[世代管理を保存するフォルダ]\[フォルダフォーマットで作成した名称のフォルダ]\[バックアップ先の絶対パスからドライブ名を除いたパス名]」という順番にフォルダを作成して、世代管理ファイルを保存します

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「世代管理」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「世代管理」をチェックしてください
「機能表示設定」でチェックしないと「世代管理」の設定項目が表示されません


  圧縮

バックアップ先にファイルを圧縮して保存します

■バックアップ先を圧縮する

バックアップ先を圧縮する場合はチェックしてください

■圧縮ファイル名

バックアップ先の圧縮ファイル名を入力してください
圧縮形式は、圧縮ファイル名の拡張子で判断されます
圧縮形式
拡張子が「.LZH」の場合は、LZH形式で圧縮されます
拡張子が「.ZIP」の場合は、ZIP形式で圧縮されます
拡張子が省略された場合は、LZH形式で圧縮されます

圧縮用DLLのインストール

BunBackupで「圧縮」機能を使用する場合は、使用する圧縮形式によりDLLが必要になります
LZH形式の場合は「UNLHA32.DLL」、ZIP形式の場合は「UNZIP32.DLL」「ZIP32J.DLL」「ZIP32.DLL」が必要になります
これらのDLLは下記のホームページよりダウンロードしてください

▼統合アーカイバ
http://www.csdinc.co.jp/archiver/
各DLLのインストール方法は、それぞれのDLLのマニュアルなどをご参照ください
なお、DLLによって使用条件が異なります
各DLLをご使用になる場合は、必ず各DLLの使用条件をご確認ください

制限事項

  • 「圧縮」を使用した場合、「高速ファイルチェック」は使用できない
  • 「圧縮」を使用した場合、「世代管理」は使用できない
（世代管理をバックアップ先とは別のフォルダに保存する場合は世代管理が利用可能）
  • 「圧縮」で形式が「ZIP」の場合、バックアップ先に作成した圧縮ファイルを一時的に保存する空き容量が必要
  • ZIP形式で圧縮時、ミラーリングで削除できないファイル名がある（ZIP関係のDLL側の問題）
  • Unicodeのファイル名は圧縮バックアップできない

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「圧縮」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「圧縮」をチェックしてください
「機能表示設定」でチェックしないと「圧縮」の設定項目が表示されません


  暗号化

ファイルを暗号化してバックアップします
BunBackupでは、「Blowfish」というアルゴリズムで暗号化します
「Blowfish」の安全性などについては、書籍やホームページなどを参照してください

■暗号化、または復号化する

バックアップ元のファイルを暗号化、または復号化(暗号を解除)してバックアップ先にコピーする場合にチェックします

■暗号化、復号化

ファイルを暗号化する場合は「暗号化」、暗号化したファイルを復号化する場合は「復号化」を選択してください

■キー

暗号化、または復号化するときのキーを入力します
キーは、半角の英数字を入力してください
全角の漢字などは使用することはできません

キーを空欄にした場合は、バックアップ時にキー入力のダイアログを表示します
（サイレントバックアップの場合は、キーが空欄の場合、キー入力のダイアログを表示しませんので注意してください）
確認入力
通常キーを入力するときには、安全のためにキーを「*」で表示するため目で確認することができません
「確認入力」ボタンをクリックしてキーを入力すると、キーを目で確認して入力することができます

注意

キーは絶対に忘れないで下さい
キーを忘れた場合は、復号することができなくなります
キーを忘れた場合は、開発側でも復号することができません

BunBackupで暗号化したファイルを復号化する方法

復号化するには3つの方法があります
●BunBackupで復号化する
上記の「復号化」を選択することで、復号化することができます
この方法を使用すると、復号化のためにほかのソフトは必要ありません
●BunRestoreで復号化する
「BunBackup設定ファイルからリストア先を設定」を選択した場合は、復号化してリストアすることができます
●BunDecodeで復号化する
BunBackupで暗号化したファイルを復号化するための専用ソフトです
このソフトに暗号化したファイルをドラグ＆ドロップするだけで簡単に復号化することができます
復号化するときのキーを保存せずに、毎回入力するようにもできるので、セキュリティ的に安心です

「BunRestore」「BunDecode」は、BunBackupを公開しているホームページで入手することができます

▼BunBackupホームページ
http://homepage3.nifty.com/nagatsuki/bunbackup/bunbackup.htm

ヒント

圧縮率
通常暗号化すると、ファイルの内容が意味不明なデータに並べ替えられるため、圧縮しても圧縮率が非常に低くなります
圧縮する場合は、圧縮してから暗号化するようにしてください
より安全性を高めるために
ファイル名がわかると、ファイルの中にどのようなデータが入っているかを想像することができます
また、拡張子がわかると、どのアプリケーションで作成したファイルかを判断することができます
そのため、ファイル名がわからないようにした方がより安全です
BunBackupではファイル名の変更を行ってしまうと、差分のバックアップができなくなってしまいますが、圧縮と暗号化を同時に利用すると、圧縮された中にどのようなファイル名が入っているかがわからなくなるため、より安全性が高くなります
その圧縮したファイルの拡張子を、手動で圧縮ファイルとはわからない拡張子にすると、さらに安全性が高くなります
（この場合は、次回バックアップするときに手動で圧縮ファイル名を元に戻してください）

暗号アルゴリズム「Blowfish」について

Blowfishは、Bruce Schneier 氏が考案したアルゴリズムで、448bit までの可変長キーを使うことができるブロック暗号アルゴリズムです
BunBackupでBlowfishを採用したのは以下の理由からです
  • 安全性が高い
  • 速い
  • 暗号時に使用するメモリが小さい
  • ライセンスフリー
  • 実績がある（さまざまな市販、オンラインソフトに採用されている）
特に大量のファイルを扱うBunBackupの場合「速い」ということは重要ですが、Blowfishは暗号にかかる時間が短く、BunBackupは最適なアルゴリズムと考えました

設定場所

「バックアップ設定」で「詳細」ボタンをクリックして「バックアップ詳細設定」を表示し、「暗号化」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「暗号化」をチェックしてください
「機能表示設定」でチェックしないと「暗号化」の設定項目が表示されません


  編集

「バックアップ設定」を参照してください


  削除

バックアップリストから削除します


  複製

バックアップリストから選択されている項目を複製します
同様の設定を繰り返す場合などに使用してください


  設定ファイルから追加

BunBackupの設定ファイル(拡張子が.lbkのファイル)から、バックアップ設定を追加します
複数に分かれているバックアップ設定を、一つの設定ファイルにまとめる場合などに使用してください


  アプリケーション名から追加

アプリケーション名を選択するだけでバックアップ元フォルダや対象ファイルを自動で設定することができます

■バックアップ先フォルダ

バックアップ先フォルダを設定します
バックアップ先フォルダのサブフォルダにアプリケーション名のフォルダを作成してバックアップします

■アプリケーション

バックアップするアプリケーションを選択します
なお、BunBackupはファイルバックアップソフトなので、レジストリなどの情報はバックアップすることができません
FirefoxやThunderbirdは、「Profile0」のユーザーのみバックアップ対象としています

注意

アプリケーションのバージョンが新しくなった場合、正しく動作しない場合があります
古いWindowsでは動作しない場合があります


  パス名置換

「バックアップ元フォルダ」、または「バックアップ先フォルダ」のパス名を置換する機能です
「場所」で置換したい場所を選択し、置換元のパス名を「検索」に、置換するパス名を「置換」に入力してください


  マイコンピュータからドラグ＆ドロップ

マイコンピュータやエクスプローラーなどからファイルやフォルダをBunBackupにドラグ＆ドロップすることでも、バックアップするフォルダやファイルを設定することができます

マイコンピュータなどからドラグ＆ドロップすると、バックアップ先を選択するダイアログを表示するのでバックアップ先を選択してください
バックアップ先の「タイトル」は、バックアップ元の最後のフォルダ名が自動的に入ります


  ツールバー

ツールバーの表示・非表示を切り替えます
「表示する」メニューにチェックがついている場合は、ツールバーを表示します

「アイコン - 小」「アイコン - 中」「アイコン - 大」メニューを選択すると、ツールバーのアイコンを切り替えることができます
ツールバーアイコンが小さくて、操作しづらい、見づらいという場合は、大きめのアイコンを選択してください


  ステータスバー

ステータスバーの表示・非表示を切り替えます
メニューにチェックがついている場合は、ステータスバーを表示します


  チェックボックス

「機能表示設定」で「選択バックアップ」をチェックしているときに、「表示」メニューの「チェックボックス」をチェックすると、バックアップリストにチェックボックスを表示します
通常「選択バックアップ」では、選択されているバックアップ設定を実行しますが、このチェックボックスを表示している場合は、チェックされているバックアップ設定を実行します


  ファイル選択リスト

「ファイル選択リスト」は、BunBackupの設定ファイル(拡張子が.lbkのファイル)をワンクリックで切り替えるためのものです

さまざまなパターンでバックアップをする場合、パターンごとに設定ファイルを作成していると設定ファイルが多くなってしまいます
「ファイル選択リスト」を使用すると、たくさんの設定ファイルがあっても簡単に切り替えることができます
また、「ファイル選択リスト」はカテゴリーでグループ化できるようになっているため、たくさんのファイルが設定されていても、目的のファイルを見つけやすくなっています

■カテゴリー

「ファイルリスト」に表示するカテゴリーを選択します
「すべてを表示」を選択すると、すべてのファイルリストを表示します

■ファイルリスト

登録されているファイルリストを表示します
ファイルリストをクリックすると、登録されているファイルを開きます
ファイルリストをダブルクリックすると、ファイル名登録のダイアログを表示します
「カテゴリー」が「すべてを表示」の場合、ファイルリストをドラグ＆ドロップすると、表示の順番を入れ替えることができます

■ファイル名登録

「ファイルリスト」にファイル名を登録します
ファイル名を登録する場合は、カテゴリーとファイル名を入力してください
カテゴリーは登録してあるものから選択することもできますし、手入力することもできます
すでに登録されているファイルは登録することができません

■ファイル名削除

ファイルリストに登録されているファイル名を削除します

■ファイル名編集

ファイルリストに登録されているファイル名を編集します

ファイル選択リスト全バックアップ

「ファイル選択リスト」を表示している状態で Shift+F10キーを押すと、ファイル選択リストに表示しているすべての設定を一括にサイレントバックアップすることができます

ヒント

バックアップリストにたくさんのバックアップ設定を登録して、選択バックアップでパターン分けしている場合は、「ファイル選択リスト」を使った方がパターンを記録できて便利かもしれません


  使用機能リスト

バックアップリストからバックアップ設定を選択すると、そのバックアップ設定で選択されている機能の一覧を表示する機能です
この機能を利用すると、バックアップ詳細設定を開かなくても、どの機能を使用しているかを一目で確認することができます


  バックアップ開始

設定されたバックアップリストの条件で、バックアップを開始します
バックアップ終了後に、バックアップされたファイルのリストを表示します
何らかのエラーがあり、バックアップできなかったファイルは、エラーリストに表示されます

バックアップ終了後表示されるファイルリスト

バックアップ終了後、コピーされたファイルとコピーできなかったファイルの一覧を表示します
コピーされたファイルリストで、フォルダ、またはファイルをダブルクリック（またはマウス左クリックでフォルダなどを選択してからマウス右ボタンクリックでメニューを表示し、「フォルダを開く」を選択）すると、そのフォルダ、またはそのファイルがあるフォルダを開きます

バックアップエラー

エラーリストにファイルが表示された場合は、そのファイルはバックアップされていません
問題を解決してから、もう一度バックアップしてください

エラーに原因につきましては、「エラーファイル」に表示されているファイルをダブルクリックするか、マウスの右ボタンでクリックし、メニューから「エラーメッセージを表示」を選択してください
エラーの原因を表示します


  バックアッププレビュー

バックアップする前に、バックアップするファイルの一覧を表示します
表示されているファイルでよければ「コピー」ボタンをクリックすると、それらのファイルをコピーします
一覧に不要なファイルがある場合は、そのファイルを選択してからDELキーを押して削除すると、削除されたファイルはコピーから除外されます

空き容量

バックアップ先の空き容量を表示します
空き容量は目安です
バックアップ先がネットワーク上の場合は、空き容量が正確ではない場合があります

プレビューに表示されているフォルダを開く

プレビューされたファイルリストで、フォルダ、またはファイルをダブルクリック（またはマウス左クリックでフォルダなどを選択してからマウス右ボタンクリックでメニューを表示し、「フォルダを開く」を選択）すると、そのフォルダ、またはそのファイルがあるフォルダを開きます

バックアップ後のファイル表示

通常の「バックアップ開始」の場合は、バックアップ後コピーされたファイルの一覧を表示しますが、バックアッププレビューからコピーした場合は、正常にコピーされればコピー後にコピーされたファイルの一覧は表示されません
ただし、コピーに失敗した場合は失敗したファイルの一覧を表示します

ヒント

バックアッププレビューは、対象ファイルや除外ファイルの動作を確認するときに便利です
実際にコピーする前に、あらかじめバックアッププレビューでコピーするファイルを確認し、不要なファイルが含まれている場合は、対象・除外ファイルを設定し直して調整してください
これを繰り返すことで、簡単に対象・除外ファイルの設定を行うことができます


  選択バックアップ

バックアップリストの中から選択したものだけをバックアップする機能です
「バックアップ開始」の場合は、バックアップリストにあるすべてのものをバックアップしますが、「選択バックアップ」では選択されたものだけをバックアップすることができます

複数を選択する場合は、CTRLキーをお押しながらクリックするか、先頭をクリックしてから終わりをSHIFTキーを押しながらクリックしてください
CTRL+Aキーを押すとすべてを選択します

機能表示設定

この機能の使用する場合は、あらかじめ「機能表示設定」で「選択バックアップ」をチェックしてください
「機能表示設定」でチェックしないと、「バックアップ」メニューに「選択バックアップ」「選択バックアッププレビュー」が表示されません


  選択バックアッププレビュー

「選択バックアップ」を参照 してください


  バックアップ後Windows終了

バックアップ終了後、Windowsを自動で終了します
パソコンによっては、Windowsを終了できない場合がありますので、事前に正しく終了できるかをチェックしてください
また、BunBackup以外にソフトが動作していた場合、Windowsを終了できない場合がありますので注意してください

機能表示設定

この機能の使用する場合は、あらかじめ「機能表示設定」で「バックアップ後終了」をチェックしてください
「機能表示設定」でチェックしないと、「バックアップ」メニューに「バックアップ後Windows終了」が表示されません


  バックアップ後BunBackup終了

Ctrl+Shift+F9キーを押してください
バックアップ終了後、BunBackupを終了します

機能表示設定

この機能の使用する場合は、あらかじめ「機能表示設定」で「バックアップ後終了」をチェックしてください
「機能表示設定」でチェックしないと、「バックアップ」メニューに「バックアップ後BunBackup終了」が表示されません


  サイレントバックアップ

F10キーを押すと「サイレントバックアップ」を実行します
バックアップ中、バックアップ後何も表示せずにバックアップします
バックアップの結果は、ログを記録すると「ログ表示」で確認することができます

なお、「サイレントバックアップ」はメニューから選択することはできません
「サイレントバックアップ」を実行したい場合は、F10キーを押してください

サイレントバックアップは、バックアップ後に何も表示しません
そのため、バックアップするファイル数が非常に多い場合は、表示に時間がかかるバックアップ結果表示を省くことによって、バックアップを短時間で行うことができます

ファイル選択リスト全バックアップ

「ファイル選択リスト」を表示している状態で Shift+F10キーを押すと、ファイル選択リストに表示しているすべての設定を一括にサイレントバックアップすることができます


  バックアップ開始(結果表示なし)

CTRL+F11キーを押すと「バックアップ開始(結果表示なし)」を実行します
動作は「バックアップ開始」と同じですが、バックアップの結果表示を行いません
バックアップの結果は、ログを記録すると「ログ表示」で確認することができます

「サイレントバックアップ」もバックアップ結果を表示しませんが、「バックアップ開始(結果表示なし)」はバックアップ中の状況を表示するダイアログは表示します

なお、「バックアップ開始(結果表示なし)」はメニューから選択することはできません
「バックアップ開始(結果表示なし)」を実行したい場合は、CTRL+F11キーを押してください

コピーするファイル数が多く、バックアップ結果表示に時間がかかる場合に便利です
特に初回のバックアップは、バックアップ元のすべてのファイルがコピーされますので、この機能を利用することでバックアップにかかる時間を節約できます


  機能表示設定

BunBackupは、できるだけわかりやすい設定にするために、「機能表示設定」でチェックされた機能の設定・メニューのみを表示するようになっています
そのため、BunBackupを使い始める前に自分に必要な機能をここで選択してください
選択されていない機能の設定・メニューは表示されません

注意

ここでは各機能の設定・メニューを表示・非表示するかを選択するだけです
ここでチェックした機能を有効にするためには、各機能を設定する場所で行ってください
機能を設定する場所は下記の機能一覧を参照してください

機能


  高速ファイルチェックDBの再構築

「高速ファイルチェック」を参照してください

「高速ファイルチェックDBの再構築」は、コマンドラインオプションからも実行できます


  自動バックアップ設定

■自動バックアップする

自動バックアップを行う場合はここをチェックしてください
ここをチェックするとバックアップ間隔の設定が行えるようになります
ここのチェックをはずすと自動バックアップを終了します

■バックアップ間隔

分ごと

間隔（分）を入力してください

時間ごと

間隔（時間）を入力してください

日ごと

間隔（日）とバックアップする時刻を入力してください

月ごと

バックアップする日と時刻を入力してください

指定時刻

一度だけ自動バックアップする場合は、ここを選択してください
バックアップする日時（年月日　時分）入力してください
（例　2003/1/1 00:00）

■Windows起動時に常駐

自動バックアップするために、Windowsの「スタートアップ」や「タスク」に登録するときに使用します

登録名

「スタートアップ」や「タスク」に登録するときの名称を入力します
ファイル名に使用することができる文字を入力してください

設定ファイル

自動バックアップするときのBunBackupの設定ファイル(拡張子が.lbkのファイル)を選択します
あらかじめBunBackupの設定を行い、「名前を付けて保存」で設定ファイルを保存しておいてください

登録先

スタートアップ

Windowsの「スタートアップ」に登録します
スタートアップに登録すると、Windows起動時にBunBackupを常駐し、BunBackupの自動バックアップ機能を使用して自動バックアップを行います

タスク

Windowsの「タスク」に登録します
タスクに登録すると、タスクで設定したスケジュールでBunBackupを起動し自動バックアップします
タスクで自動バックアップする場合は、BunBackupの「自動バックアップ」機能は使用しないため、BunBackupを常駐させる必要はありません
タスクの設定方法はWindowsのタスクについてのヘルプを参照してください

設定場所

「設定」メニューの「環境設定」で、「自動バックアップ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「自動バックアップ」をチェックしてください
「機能表示設定」でチェックしないと「自動バックアップ」の設定項目が表示されません

自動バックアップ


  監視

■ドライブを監視し接続されるとバックアップを開始する

ドライブを監視して、メディアが挿入されたり、USBメモリなどが接続されたときに、自動的にバックアップを開始したい場合はチェックしてください

■プレビューする

バックアップ開始時に、バックアッププレビューを表示したい場合はチェックしてください

■サイレントバックアップする

バックアップ時、バックアップ中のウインドウやバックアップ結果を表示させたくない場合はチェックしてください

■ボリュームラベルによって設定ファイルを切り替える

ドライブが接続されたときにボリュームラベルをチェックし、そのボリュームラベルに関連づけられた設定ファイルを開いて、バックアップを開始します
リムーバブルメディアにバックアップしている場合は、メディアによって自動的に設定ファイルを切り替えることができるため便利です
また、USBストレージにバックアップしている場合は、接続と同時にバックアップを開始することができます

■バックアップ後イジェクトする

バックアップ後に接続されたドライブをイジェクトします
バックアップ先がリムーバブルディスクの場合に使用してください
パソコンによってはイジェクトされない場合もあります
あらかじめご確認の上使用してください

■バックアップ後安全な取り外し

バックアップ後に接続されたドライブに、Windowsの「ハードウェアの安全な取り外し」を実行します
この機能が使用できるのは、Windows2000/XPでUSB接続のものだけです
バックアップ先がUSB接続の場合に使用してください
パソコンによっては安全な取り外しができない場合もあります
あらかじめご確認の上使用してください

注意

「ドライブ接続監視バックアップ」機能を使用する場合は、BunBackupが起動している必要があります

設定場所

「設定」メニューの「環境設定」で、「監視」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ドライブ接続監視バックアップ」をチェックしてください
「機能表示設定」でチェックしないと「ドライブ接続監視バックアップ」の設定項目が表示されません

ドライブ接続監視バックアップ


  ログ設定

バックアップの結果をファイルに記録します
ログに記録されたバックアップ結果は「ログ表示」で確認することができます

■ログを記録する

ログを記録する場合はここをチェックしてください

■ログファイル名

ログを記録するファイル名を設定してください

■記録回数

ログを記録する回数を設定してください
ログの記録がこの回数を超えると、古いものから削除されます
0回を設定すると、古い記録を削除せずにログに追加していきます

設定場所

「設定」メニューの「環境設定」で、「ログ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ログ」をチェックしてください
「機能表示設定」でチェックしないと「ログ」の設定項目が表示されません

ログ


  タスクトレイ

WindowsのタスクトレイにBunBackupのアイコンを表示します
「タスクトレイにアイコンを表示する」をチェックすると、タスクトレイに表示します

そのアイコンをマウスの右ボタンでクリックすると、下記のメニューを表示します

  • バックアップ開始
  • バックアッププレビュー
  • 開く
  • 環境設定
  • 終了

サイレントバックアップ時、エラーがあると点滅する

「自動バックアップ」や「サイレントバックアップ」時に、バックアップできなかったエラーファイルがある場合、タスクトレイアイコンを点滅することができます

設定場所

「設定」メニューの「環境設定」で、「タスクトレイ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「タスクトレイアイコン」をチェックしてください
「機能表示設定」でチェックしないと「タスクトレイアイコン」の設定項目が表示されません


  優先度

BunBackupがバックアップを実行する場合、「BunBackupの優先度を下げる」をチェックしていると、バックアップ中に他のソフトが動作しているときはそちらを優先します

この機能を利用することで、他のソフトの動作が重くなることなくスムーズに操作することができます
自動バックアップなど、バックグランドでバックアップするときにこの機能を使用すると便利です

なお、この機能を使用すると、他のソフトが動作中はバックアップ時間がかかります

設定場所

「設定」メニューの「環境設定」で、「優先度」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「優先度」をチェックしてください
「機能表示設定」でチェックしないと「優先度」の設定項目が表示されません


  バックアップ後音を鳴らす

バックアップ終了後、指定されたWAVファイルを鳴らします

設定場所

「設定」メニューの「環境設定」で、「音を鳴らす」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「バックアップ後音を鳴らす」をチェックしてください
「機能表示設定」でチェックしないと「バックアップ後音を鳴らす」の設定項目が表示されません


  ファイル履歴数設定

「ファイル」メニューに表示するファイルの履歴の数を設定します
ファイル履歴は、ファイルを「開く」「名前を付けて保存」を行うと更新されていきます
「ファイル履歴のクリア」ボタンをクリックすると、ファイル履歴をクリアします

設定場所

「設定」メニューの「環境設定」で、「ファイル履歴」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ファイル履歴設定」をチェックしてください
「機能表示設定」でチェックしないと「ファイル履歴設定」の設定項目が表示されません


  フォント

BunBackupの画面のフォントを変更します
「バックアップリスト」「ファイル選択リスト」「バックアップ結果・プレビュー」のフォントを設定します


  レジストリ

環境設定の内容や、BunBackupについての情報を、どこに保存するかを選択します
初期値では、レジストリを使用しない設定になっています
レジストリに情報を保存しない場合は、BunBackup.ini、BunBackup.env(環境設定の内容)というファイルに保存します

レジストリを使用する

環境設定の内容や、BunBackupについての情報をレジストリに保存する場合は、ここをチェックしてください

ヒント

一つのパソコンで複数のユーザーが使用する場合は、レジストリを使用することを推奨します
レジストリを使用すると、ログインするユーザーによって異なる設定にすることができます


  関連付け

WindowsにBunBackupファイル(*.lbk)を関連付けします
関連付け後は、Windowsの「マイコンピューター」などからBunBackupファイルを開くと、自動的にBunBackupが起動し、BunBackupファイルを開きます


  バックアップ設定

■タイトル

タイトルは何を入力してもかまいません
後から見てわかりやすいタイトルをつけてください

■バックアップ元フォルダ

バックアップしたファイルがあるフォルダを設定してください
入力する部分の右側にあるボタンをクリックすると、フォルダの一覧を表示しますので、その中からフォルダを選択することができます
フォルダ名には最後に「\」つけないようにしてください
（例　C:\My Documents）

「バックアップ元フォルダ」とかかれているラベルをダブルクリックすると、そのフォルダを開きます
「バックアップ元フォルダ」とかかれているラベルをマウスの右ボタンでクリックするとメニューを表示します
「フォルダを開く」を選択するとバックアップ元フォルダを開きます

■バックアップ先フォルダ

ファイルをコピーしておくフォルダ(バックアップ先)を設定してください
入力する部分の右側にあるボタンをクリックすると、フォルダの一覧を表示しますので、その中からフォルダを選択することができます
フォルダ名には最後に「\」つけないようにしてください
（例　C:\My Documents）

「バックアップ先フォルダ」とかかれているラベルをダブルクリックすると、そのフォルダを開きます
「バックアップ先フォルダ」とかかれているラベルをマウスの右ボタンでクリックするとメニューを表示します
「フォルダを開く」を選択するとバックアップ先フォルダを開きます
「空き容量」を選択するとバックアップ先の空き容量を表示します
空き容量は目安です
バックアップ先がネットワーク上の場合は、空き容量が正確ではない場合があります
間接指定
ボリュームラベルからドライブを間接指定
接続するたびにドライブ名が変わってしまう環境の場合は、ドライブ名をボリュームラベルから間接的に指定することができます
ドライブ名を「<VOL_○○○>」(○はボリュームラベル)で記述してください

例）　ボリュームラベルが「USBMemory」というUSBメモリの「Backup」というフォルダにバックアップする場合
    <VOL_USBMemory>\Backup

■詳細

「バックアップ詳細設定」を開きます

詳細を設定しない場合は、バックアップ元フォルダとバックアップ先フォルダにあるファイルを比較し、新しいファイル・変更があったファイルをバックアップ先フォルダにコピーします（差分バックアップ）
フォルダにサブフォルダがある場合は、サブフォルダも同様にコピーします


  バックアップ詳細設定

バックアップの詳細な条件を設定します

一部の機能は「機能表示設定」でチェックしないと、設定項目が表示されないものがあります

「バックアップ方法」タブ

サブフォルダもバックアップする
バックアップ方法
対象ファイル
除外ファイル
ミラーリング

「ボリュームラベル」タブ

ボリュームラベル

「ログイン」タブ

ネットワークログイン

「世代管理」タブ

世代管理

「ファイルチェック」タブ

上書きするときに警告を出す
高速ファイルチェック
コピーエラー時バックアップ先ファイルを保護

「除外フォルダ」タブ

除外フォルダ

「圧縮」タブ

圧縮

「暗号化」タブ

暗号化


  環境設定

BunBackupの設定を行います

自動バックアップ

ドライブ接続監視バックアップ

ログ

タスクトレイ

優先度

バックアップ後音を鳴らす

ファイル履歴数設定

フォント

レジストリ

関連付け


  自動バックアップ

「自動バックアップ」は、一定間隔、指定時刻などに自動的にバックアップを実行する機能です

「機能表示設定」で「自動バックアップ」機能をチェックし、「環境設定」で「自動バックアップする」をチェックすると、一定の間隔（または指定した時刻）で自動的にバックアップをします
自動バックアップを開始すると、BunBackupのステータスバー（ウインドの下部）に次に自動バックアップする日時を表示します

自動バックアップを開始すると、BunBackupを最小化したときには、Windowsのタスクトレイの通知領域（Windowsの時計などが表示されているところ）にBunBackupが入ります
そのBunBackupをマウスの左ボタンでクリックするとBunBackupが通常状態に復帰し、マウスの右ボタンでクリックするとメニューを表示します
自動バックアップの結果は、「ログ」を記録すると後から確認することができます

Windowsのタスクを利用した自動バックアップ

BunBackupでは、自動バックアップする場合はこの機能を利用する方法と、Windowsのタスクを利用する方法があります。Windowsのタスクを利用したバックアップの方法は「Windowsのタスクから自動バックアップしたいのですが」をご参照ください。タスクでの自動バックアップは設定が複雑ですが、条件が細かく設定できます

設定場所

「設定」メニューの「環境設定」で、「自動バックアップ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「自動バックアップ」をチェックしてください
「機能表示設定」でチェックしないと「自動バックアップ」の設定項目が表示されません


  ドライブ接続監視バックアップ

ドライブを監視して、ドライブが接続されると自動的にバックアップを開始します
DVD-RAMなどのリムーバブルディスクや、USBメモリなどのUSBストレージにバックアップするときに便利な機能です

バックアップする設定ファイルを開き、メディアを挿入(またはUSBに接続)すると、自動的にバックアップを開始します
バックアップリストで接続したドライブと同じものを検索し、選択してバックアップします
ボリュームラベルの設定をしている場合は、ボリュームラベルが同じバックアップ設定を選択してバックアップします

注意

「ドライブ接続監視バックアップ」機能を使用する場合は、BunBackupが起動している必要があります

設定場所

「設定」メニューの「環境設定」で、「監視」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ドライブ接続監視バックアップ」をチェックしてください
「機能表示設定」でチェックしないと「ドライブ接続監視バックアップ」の設定項目が表示されません


  ログ表示

記録したログを表示します
ログ表示を選択すると、日時ことにログの一覧を表示します
表示したいログを選択し、「OK」ボタンをクリックしてください
その日時にバックアップしたファイルの一覧を表示します

設定ファイル別表示

「すべてを表示」をクリックすると、ログに記録されている設定ファイル一覧を表示します
表示したい設定ファイルを選択すると、その設定ファイルだけのログ一覧を表示します

バックアップエラー

エラーに原因につきましては、「エラーファイル」に表示されているファイルをダブルクリックするか、マウスの右ボタンでクリックし、メニューから「エラーメッセージを表示」を選択してください
エラーの原因を表示します

ログ設定


  ログ

バックアップした結果をファイルに記録します
ログに記録されたバックアップ結果は、「ログ表示」で確認することができます
ログファイルはテキストファイルになっているため、メモ帳やエディタなどテキストファイルを開くことができるソフトでも表示することができます

設定場所

「設定」メニューの「環境設定」で、「ログ」タブをクリックします

機能表示設定

この機能の設定する場合は、あらかじめ「機能表示設定」で「ログ」をチェックしてください
「機能表示設定」でチェックしないと「ログ」の設定項目が表示されません


  コマンドラインオプション

BunBackupは、コマンドラインから起動する場合に、オプションをつけることができます。
オプションを指定する場合は、オプションの前にハイフン「-」、またはスラッシュ「/」をつけます。オプションは大文字小文字の区別はありません。

例　BunBackup.exe /AUTO

オプションによっては、オプションの後にファイル名を指定することができます。ファイル名を指定するときにはオプションの後にコロン「:」をつけてフルパスでファイル名を記述してください。
ファイル名やフォルダ名にスペースが入っている場合は、ファイル名やフォルダ名をダブルクォーテーション「"」で囲ってください。

例
BunBackup.exe /WINMIN
BunBackup.exe /AUTO:"C:\My Documents\BunBackup\Test.lbk"

オプション

設定ファイル名(*.lbk)

BunBackupの設定ファイル名(拡張子が.lbkのファイル)を指定すると、BunBackup起動時にそのファイルを開きます。
（例：　BunBackup.exe "C:\My Documents\BunBackup\Test.lbk"）

BACKUP

BunBackup起動後、前回開いたBunBackup設定ファイル(*.lbk)からバックアップを実行し、バックアップ結果を表示します。
「BACKUP」の後にBunBackup設定ファイルを指定した場合は、そのバックアップを実行します。
（例：　BunBackup.exe /BACKUP:"C:\My Documents\BunBackup\Test.lbk"）

NORESULT

このオプションを指定するとバックアップ結果を表示しません。
（例：　BunBackup.exe /BACKUP:"C:\My Documents\BunBackup\Test.lbk" /NORESULT）

AUTO

BunBackup起動後、前回開いたBunBackup設定ファイル(*.lbk)からバックアップを実行し、BunBackupを終了します。
「AUTO」の後にBunBackup設定ファイルを指定した場合は、そのバックアップを実行します。
「BACKUP」はバックアップの動作や結果を表示しますが、「AUTO」はバックアップ中の動作やバックアップ結果を表示しません（サイレントバックアップ）。
（例：　BunBackup.exe /AUTO:"C:\My Documents\BunBackup\Test.lbk"）

WINEXIT

BunBackupを終了後、Windowsも終了します。
設定方法は「AUTO」と同様です。
パソコンによってはWindowsを終了できない場合があります。

WINSTAND

BunBackupを終了後、Windowsをスタンバイにします。
設定方法は「AUTO」と同様です。
パソコンによってはWindowsをスタンバイできない場合があります。

WINHIBER

BunBackupを終了後、Windowsを休止状態にします。
設定方法は「AUTO」と同様です。
パソコンによってはWindowsを休止状態にできない場合があります。

WINREBOOT

BunBackupを終了後、Windowsを再起動します。
設定方法は「AUTO」と同様です。
パソコンによってはWindowsを再起動できない場合があります。

WINMIN

BunBackupを最小化して起動します

TASKTRAY

WindowsタスクトレイにBunBackupのアイコンを表示します（常駐）

FILELISTDB

高速ファイルチェック時、キャッシュファイルを指定します。
（例：　BunBackup.exe /FILELISTDB:"C:\My Documents\BunBackup\Test.DB"）
「FILELISTDB」を指定しない場合は、BunBackupをインストールしているフォルダに「FileList.his」というファイルを作成し、これをキャッシュファイルとして使用しますので、通常このオプションを設定する必要はありません。

WORKDIR

圧縮時に使用する一時ファイルを保存するフォルダを指定します
（例：　BunBackup.exe /WORKDIR:"C:\My Documents"）
WORKDIRが指定できるのは、圧縮形式がLZH形式のときだけです

ENV

環境設定ファイルを指定します
（例：　BunBackup.exe /ENV:"C:\My Documents\Test.env"）
このオプションを使用することで、ショートカットごとに環境設定ファイルを切り替えることができます
なお、この機能はBunBackup起動時に読み込む環境設定ファイルを指定するだけで、「環境設定」で変更された内容はこの環境設定ファイルに保存されません

DESTNOCHECK

バックアップ先の存在チェックを省略します

ACLCOPY

ファイルコピー時にACL情報もコピーします
このコマンドラインオプションは、Windows2000/XPで、バックアップ先・元のフォーマットがNTFSのときのみ有効です
このコマンドラインを指定すると、ファイルをコピーした後にACL情報をコピーするため、通常のコピーよりも時間がかかります
ACL情報がコピーされるのは、ファイルをコピーするときだけです
ACL情報だけを変更してもACL情報はコピーされません

RESETFILELISTDB

高速ファイルチェックDBの再構築を行います
再構築後はBunBackupを終了します
このコマンドラインオプションを使用する場合は、先に設定ファイルを指定してください
（例：　BunBackup.exe "C:\My Documents\BunBackup\Test.lbk" /RESETFILELISTDB）
高速ファイルチェックDBファイルを指定する場合は「RESETFILELISTDB」の後に「:」をつけてファイル名を指定してください
（例：　BunBackup.exe "C:\My Documents\BunBackup\Test.lbk" /RESETFILELISTDB:"C:\My Documents\BunBackup\Test.DB"

ヒント

AUTOコマンドを利用して、Windowsのタスクから自動的なバックアップ(一定間隔ごと、指定時刻など、詳しくWinodwsのタスクを参照してください)を行うことができます。
タスクを利用した自動バックアップ

設定例

BunBackup.exeが「C:\Program Files\BunBackup\」にあるとします
下記の設定を「リンク先」に設定します

Windowsのスタートアップに登録する場合
"C:\Program Files\BunBackup\BunBackup.exe" /WINMIN /TASKTRAY

Windowsのタスクに登録する場合、Windowsのデスクトップにショートカットを作成してバックアップする場合
バックアップする設定ファイルが「C:\My Documents\BunBackup\Test.lbk」とします
"C:\Program Files\BunBackup\BunBackup.exe" /AUTO:"C:\My Documents\BunBackup\Test.lbk"


  バックアップするメディア

フロッピーディスク

昔は一般のパソコンで誰でも使えるバックアップメディアといえば、フロッピーディスクしかありませんでした
フロッピーディスクは保存できるサイズが非常に少なく、書き込み速度も遅いため、バックアップに向いているメディアとはいえませんでした

ハードディスク

別のハードディスクドライブにバックアップしている場合でも、一つのハードディスクを複数のドライブに分割している場合は、そのハードディスクが故障してしまえば、どちらのドライブのファイルも被害を受ける可能性があるため、バックアップとしてはよい方法ではありません
ハードディスクにバックアップする場合は、もう一つ別のハードディスクを用意する必要があります
最近は、USBで接続できる外付けハードディスクがありますので、これを利用すると便利です

CD-R/RW

最近では、CD-R/RWがついているパソコンも多くなりました
CD-R/RWは、フロッピーディスクと比較と比較すると、大容量で書き込みスピードも速く、メディアも安いため、簡易的なバックアップのメディアとしては最適です
CD-R/RWは、通常ですとファイル単位での書き込みができませんが、パケットライティングソフトを使用することで、擬似的にフロッピーディスクやMOなどと同様に扱うことができるようになるため、バックアップには非常に便利です
パケットライティングソフトで書き込んだCDは、読み込む場合にも読み込み用ソフトが必要ですが、読み込み用ソフトはフリーソフトとしてホームページからダウンロードできるものもありますので、このソフトをインストールすれば、様々なパソコンでの読み込みが可能になります

DVD関連

まだドライブが若干高めではありますが、DVD-R/-RW/+R/+RWなども普及してきました
これらのドライブが安価になってくれば、さらに大容量のメディアをバックアップに利用しやすくなります


  バックアップするファイル

通常、バックアップが必要なのは自分で作成したデータファイルや、ソフトの設定が保存されているファイルなどです

ソフトによっては、どのファイルをバックアップすればよいかをマニュアルなどに記述している場合もありますし、ホームページのFAQなどに記述されている場合もありますので、あらかじめ確認しておいた方がいいでしょう

バックアップから除外するファイル

実行ファイル

ソフト自体はインストールし直すことで、復旧することができます
そのため、インストールCD-ROMなどに入っていて、ハードディスク上で変更されない、拡張子が「.exe」や「.dll」のファイルは、バックアップの必要はないと考えられます

テンポラリファイル

ソフトで一時的な使用のために保存されているテンポラリファイルなどもバックアップから除外して良いと考えられます


  リストアの方法

BunBackup単体には、「リストア」という機能がありません。
バックアップメディアから必要なファイルを、リストアしたいフォルダに上書きコピーしてください
BunBackupでリストアする場合は、バックアップ先とバックアップ元のフォルダを入れ替えて、「詳細」で「バックアップ方法」を「常に上書き」することでリストアできます

なお、暗号化している場合は、「復号化する」でリストアしてください
また、圧縮している場合は、一度解凍してからリストアしてください

現在BunBackup単体にリストアの機能をつけていないのは、できるだけソフトの設定をシンプルにしたいのと、誤ってリストアしてしまった場合、バックアップ元のファイルが書き換えられてしまう危険があるために、今のところあえてつけていません。
今後要望が多いようでしたら、リストアの機能を追加したいと思います

リストア用ソフト

BunBackup専用のリストアソフトを下記のホームページで公開しています
このソフトを使用すると簡単にリストアすることができます
また、暗号化、圧縮のリストアにも対応しています

BunRestore
http://homepage3.nifty.com/nagatsuki/bunbackup/restore/BunRestore.htm

リストアの方法は？


  タスクを利用した自動バックアップ

WindowsのタスクとBunBackupのコマンドラインオプションを使用して、自動的に(一定間隔ごと、指定時刻など、詳しくWinodwsのタスクを参照してください)バックアップを実行することができます。

設定方法

  1. Windowsにタスクを一つ追加する
  2. BunBackup.exeのファイルを指定する
  3. タスクの実行方法(日単位、週単位、コンピュータ起動時など)を選択する
  4. タスクの設定が終わったらそのタスクを開き、「実行するファイル名」に「"--BunBackupのフルパス--\BunBackup.exe" /AUTO:"--BunBackupの設定ファイル(*.lbk)を記述--"
  5. 設定例：　"C:\Program Files\BunBackup\BunBackup.exe" /AUTO:"C:\My Documents\BunBackup\Test.lbk"
  6. 「OK」ボタンをクリックしてタスクの設定を終了する

コマンドラインオプション


  リストアの方法は？

BunBackupはファイルバックアップなので、基本的にはバックアップ先フォルダからバックアップ元フォルダににコピーすることでリストアできます
そのため、リストア方法としては、主に三つの方法があります

マイコンピュータ、エクスプローラー、ファイラーなどからコピー

Windowsのマイコンピュータなどから、バックアップ先フォルダにあるすべてのファイルをバックアップ元にコピーしてください

BunBackupからリストア

バックアップ時に使用した設定ファイル(拡張子が.lbk)をBunBackupから開き、「バックアップ設定」の「バックアップ元フォルダ」と「バックアップ先フォルダ」を入れ替えてバックアップしてください
なお、フォルダを入れ替える場合は、「バックアップ元フォルダ」または「バックアップ先フォルダ」と書かれているラベルをマウスの右ボタンでクリックするとメニューを表示しますので、「バックアップ元とバックアップ先を入れ替える」を選択すると、「バックアップ元フォルダ」と「バックアップ先フォルダ」を入れ替えることができます

BunRestoreからリストア

世代管理、圧縮、暗号化などを使用している場合は、BunRestoreを使用した方が便利です
BunRestoreからリストアする方法は以下の通りです

BunBackupの設定ファイルが手元にある場合

  1. 「BunBackup設定ファイルからリストア先を設定」を選択する
  2. 「BunBackupの設定ファイル」を入力する
  3. 「リストア」ボタンをクリックする

BunBackupの設定ファイルがない場合

  1. 「リストア元・先フォルダを設定」を選択する
  2. バックアップ時に「バックアップ先フォルダ」としたフォルダを「リストア元フォルダ」に入力する
  3. バックアップ時に「バックアップ元フォルダ」としたフォルダを「リストア先フォルダ」に入力する
  4. 「リストア」ボタンをクリックする

▼BunRestore
http://homepage3.nifty.com/nagatsuki/bunbackup/restore/BunRestore.htm


  コピーできないファイルがあります

コピーできないファイルがある場合は、「コピー結果」または「ログ」の「エラーファイル」覧にあるファイルをダブルクリックしてください
エラーファイルになった原因を表示します
原因を確認して問題を解決してから、再度バックアップしてください

エラーの原因としては、たとえば以下のようなものがあります。

デバイスの準備ができていません

バックアップ先にメディアが入っていない可能性があります。

ディスクに十分な空き領域がありません

バックアップ先の空き容量が足りない可能性があります。

別のプロセスが使用中です

ほかのアプリケーション、またはOSからロックされている可能性があります。 ほかのアプリケーションがロックしている場合は、そのアプリケーションを終了してからバックアップしてください。
OSからロックされていて、ロックをはずすことができないファイルは、BunBackupからバックアップすることはできません。

フルパス名が260文字(半角)をこえるファイル

Windowsにはフルパス名が260文字(半角)以内という制限があります。そのため、この制限をこえたファイル名の場合は、動作が不定(コピーできる場合もあれば、エラーとなる場合もある)となり、コピーできない場合があります。


  ファイル数やファイル容量の制限はありますか？

ファイル数については、Windowsが使えるメモリに依存します
ソフト的に特に制限を設けていませんが、ファイル数が極端に多い場合は、メモリ不足によりバックアップできない場合があります

コピーできる一つのファイルの最大サイズは、ドライブのファイルシステムに依存します
FATは2Gバイトまで、FAT32は4Gバイトまで、NTFSは2Tバイトまでとなります


  コピーやミラーリングによって更新・削除されるファイルを事前に確認したい

あらかじめ、バックアップによりコピーされるファイル、ミラーリングにより削除されるファイルを確認したい場合は、「バックアップ」メニューの「バックアッププレビュー」を実行してください
「バックアッププレビュー」は、実際にバックアップする前に、コピー・削除するファイルの一覧を表示します
コピー・削除から除外したいファイルがある場合は、その一覧から削除することでバックアップ対象から外すことができます
「バックアッププレビュー」でコピー・削除するファイルを確認したら、「コピー」ボタンをクリックするとバックアップを開始します


  設定手順がわかりません

簡単な設定手順をご説明します

  1. 「設定」メニューの「機能選択」で使用したい機能をチェックしてください
  2. 「設定」メニューの「環境設定」でそれぞれの機能の設定を行ってください
  3. ヘルプの「バックアップ手順」に従って、バックアップ元・先フォルダなどの基本の設定を行ってください
  4. さらに詳細な設定が必要な場合は、「バックアップ詳細設定」で設定を行ってください
  5. 「ファイル」メニューにある「名前を付けて保存」で現在の設定をファイルに保存してください
  6. すべての設定が終了したら「バックアップ」メニューにある「バックアップ開始」を選択してください


  機能表示設定でチェックしても機能が働きません

「設定」メニューの「機能選択」では、各機能の設定・メニューを表示・非表示するかを選択するだけなので、チェックした機能を有効にするためには、各機能を設定する場所で行ってください
詳しくは「機能選択」をご参照ください


  Windows起動時にBunBackupを常駐したいのですが

Windows起動時にBunBackupを常駐させる場合は、Windowsの「スタートアップ」にBunBackupのショートカットを作成してください

１．BunBackupのショートカットを作成する
    BunBackup.exeをマウスの右ボタンでクリックし、「ショートカットの作成」をクリックすると、ショートカットを作成できる
２．Windowsの「スタートアップ」を開く
３．「スタートアップ」にBunBackupのショートカットを移動する
４．BunBackupのショートカットをマウスの右ボタンでクリックし、「プロパティ」を開く
５．現在表示されている「リンク先」の最後に「/WINMIN /TASKTRAY」を追加する
    「リンク先」の入力例：「"C:\Program Files\BunBackup\BunBackup.exe" /WINMIN /TASKTRAY」

Bunbackupユーティリティー

これらの設定は「BunBackupユーティリティー」を使用すると簡単にです
「BunBackupユーティリティー」は下記のホームページよりダウンロードできます
http://homepage3.nifty.com/nagatsuki/bunbackup/utility/utility.htm

設定手順は以下の通りです
１．「BunBackupユーティリティー」を起動する
２．「作成場所」で「スタートアップ」を選択する
３．「最小化で起動」をチェックする
４．「タスクトレイにアイコンを表示」をチェックする
５．「起動後バックアップ開始」のチェックをはずす
６．「BunBackupの設定ファイル」でバックアップに使用する設定ファイルを選択する
７．「ショートカット作成」ボタンをクリックする

自動バックアップはBunBackupとタスクどちらで行った方がいいですか？


  Windowsのタスクから自動バックアップしたいのですが

自動バックアップを行う場合、BunBackupの自動バックアップ機能を使う方法と、Windowsのタスクを利用して自動バックアップをする方法があります
Windowsのタスクを利用した方が、より柔軟にスケジュールを設定することができますし、BunBackupを常駐させる必要がありませんので、パソコンかかる負荷が少なくなります

BunBackupから設定

1. BunBackupを起動する
2. 「設定」メニューの「機能選択」を選択する
3. 「自動バックアップ」をチェックしOKボタンをクリックする
4. 「設定」メニューの「環境設定」を選択する
5. 「自動バックアップ」タブをクリックする
6. 「Windows起動時に常駐」ボタンをクリックする
7. 「設定ファイル」にバックアップに使用する設定ファイルを入力する
8. 「登録先」で「タスク」を選択する
9. 「登録」ボタンをクリックする
10. Windowsにログインするときの「アカウント」と「パスワード」を入力する
11. 「スケジュール」タブの「タスクのスケジュール」で「日単位」を選択する
12. 「開始時刻」にバックアップを開始する時刻を入力する

Windowsのタスクから設定

Windowsのタスクの設定は、BunBackupではなく、タスク側で行う必要があります
タスクの設定方法は、Windowsによって異なることがありますが、おおよそ下
記の手順で行います
（詳しくWinodwsのタスクのヘルプを参照してください)

1.Windowsの「スタート」から「設定」－「コントロールパネル」－「タスク」－「スケジュールされたタスクの追加」を選択します
2.タスクを設定するウィザードが起動します
3.「次へ」ボタンをクリックします
4.「参照」ボタンをクリックしてBunBackup.exeを選択します
5.タスクを実行する間隔を選択し、「次へ」ボタンをクリックします
6.タスクの設定をします
7.ユーザー名とパスワードを設定します
8.「[完了]をクリックしたときに詳細プロパティを開く」をチェックして、「完了」ボタンをクリックします
9.「タスク」タブの「実行するファイル名」にコマンドラインオプションの設定をします

設定方法
"--BunBackupのフルパス--\BunBackup.exe" /AUTO:"--BunBackupの設定ファイル(*.lbk)を記述--"

設定例
"C:\Program Files\BunBackup\BunBackup.exe" /AUTO:"C:\My Documents\BunBackup\Test.lbk"

１０．「OK」ボタンをクリックしてタスクの設定を終了します

これで、Windowsのタスクに登録されます

自動バックアップはBunBackupとタスクどちらで行った方がいいですか？


  自動バックアップはBunBackupとタスクどちらで行った方がいいですか？

BunBackupでは、自動バックアップを行う場合、BunBackup単体で行う方法と、Windowsのタスクを利用する方法の二通りがあります
どちらを利用して基本的に変わりはありませんが、下記のような利点と欠点があります

BunBackup単体で自動バックアップする場合

  • Windowsのタスクを利用しなくても行えるため設定が簡単
  • BunBackupが常駐することになるため、メモリやCPUパワーを若干消費する
  • バックアップのイベントは、Windowsのタスクを利用した方が細かく設定できる

自動バックアップ参照

Windowsのタスクを利用して自動バックアップする場合

  • バックアップのイベントを細かく設定できる
  • BunBackupが常駐しないため、メモリやCPUパワーを節約できる
  • Windowsのタスクの設定方法を理解する必要がある
  • BunBackupのコマンドラインの設定方法を理解する必要がある

コマンドラインオプション参照

Windowsのタスクから自動バックアップしたいのですが
Windows起動時にBunBackupを常駐したいのですが


  ミラーリングされません

「バックアップ詳細設定」で「ミラーリングする」をチェックしても、バックアップ先のファイルが削除されない場合があります
このような場合は、下記の点を確認してください

  • 削除されるファイルをほかのソフトで開いていないか
  • 削除されるファイルをほかのユーザーと共有していないか
  • 削除されるファイルのアクセス権があるか

削除しようとしているファイルが使用中の場合は、削除できない場合があります

わたしの方では未確認なのですが、ユーザーの方からBHAのB's Clip Ver.3.37というCD-R/RW用パケットライトソフトを使用すると、バックアップ自体は正常に行えるが、ミラーリングでファイルの削除ができないという報告がありました
もし同様の現象を確認されている方、または正常に動作しているという方がいらっしゃいましたら、お手数ですがNagatsukiまでご連絡ください


  高速ファイルチェックを使用しているのにバックアップ時間が短縮されません

「高速ファイルチェック」は、バックアップ先のファイル情報を、BunBackupがあるHDDにキャッシュすることで、ファイルチェック時間を短縮しています
そのため、バックアップ先のアクセススピードがキャッシュがあるHDDよりも速い場合は効果がありません
また、キャッシュから情報を得るためにはある程度のCPUパワーが必要なため、バックアップ先のアクセススピードとCPUパワーのバランスによっては、ファイルチェック時間を短縮できない場合があります


  分割バックアップはできないのですか？

BunBackupは分割バックアップの機能はないのですが、「高速ファイルチェック」機能を利用して、擬似的に分割バックアップを行うことができます
詳しくは「高速ファイルチェック」の「高速ファイルチェックのちょっと変わった使い方」を参照してください

なお、この方法では「ミラーリング」「世代管理」を正しく行うことはできません


  圧縮形式でLZHやZIP以外の形式はサポートしていないのですか？

非サポートになりますが、CABやTARなどの形式でも圧縮することができます
ただし、LHZ、ZIP以外の形式の場合は、圧縮用ライブラリの制限で、圧縮ファイルに対する追加・削除を行うことができないません
そのため、バックアップするたびに古い圧縮ファイルを削除してからバックアップを行います

LHZ、ZIP以外の形式で圧縮する場合に必要なDLL

CAB 形式
    CAB32.DLL
TAR/BZ2/TGZ形式
    TAR32.DLL
BZA/GZA形式
    BGA32.DLL
YZ1形式
    YZ1.DLL

これらのDLLは、LZHやZIP同様下記のホームページから入手してください
▼統合アーカイバ
http://www.csdinc.co.jp/archiver/

なお、LHZ、ZIP以外の形式は十分な動作テストを行っていません
使用には十分注意してください
何か不具合を確認された場合には、Nagatsukiまでご連絡ください


  空フォルダが削除されません

「高速ファイルチェック」機能を使用していてミラーリングしている場合、フォルダのミラーリングは行われません
高速ファイルチェックでは、バックアップ先のフォルダ情報を持っていないため、バックアップ元で削除されたフォルダをミラーリングでは削除されません
この場合は、BunBackupユーティリティーを使用して、バックアップ先の空フォルダを削除してください
なお、高速ファイルチェックを使用しない場合は、バックアップ元のフォルダを削除すると、ミラーリングによってバックアップ先のフォルダも削除されます


  「ログファイルが壊れている可能性があります」というエラーが出ます

このエラーが出る原因としては

  • ログファイルをBunBackup以外のアプリケーションで開き保存したためフォーマットが壊れた
  • 日本語Windowsが対応していない文字コードが使われているファイル名がある
  • HDDの一部が壊れている
  • 空のログファイルが存在している
  • ウイルスに感染しているファイルがある

などが考えられます
このエラーが出た場合は、念のためにHDDのエラーチェックを行い、HDDに問題なければ、Unicodeやウムラウトなどが使用されているフルパス名がないかを確認してください


  メニューなどが文字化けします

日本語WindowsXPを使用している場合

「コントロールパネル」の「地域と言語オプション」で、「標準と形式」が「日本語」になっているかを確認してください

日本語以外のWindowsXPを使用している場合

以下の手順で確認してください

1. [Control Panel] の
    [Date,Time,Language and Regional Option] を開く

2. [Regional and Language Option]を開く

3. [Languages]タブにある
    [Supplemental language support]で
    [Install files for East Asian languages]にをチェックする

4. [Regional Option]タブで[Japanese]を選択する

5. [Advanced]タブにある
    [Language for non-Unicode programs]で
    [Japanese]を選択する

これで動作しないようであれば、Microsoftから[AppLocale Utility]というユ
ーティリティーを配布しています

▼AppLocale Utilityダウンロードページ
http://www.microsoft.com/downloads/details.aspx?FamilyID=16712f0b-a935-4140-9163-1514c89f6ddd&displaylang=ja

このユーティリティーを利用すると、文字化けを解消できる場合があります


  CD-RやDVD-Rなどにバックアップできますか？

BunBackupから直接CD-RやDVD-Rなどにバックアップすることはできません
市販のパケットライトソフトを利用すると、BunBackupからCD-Rなどにバックアップすることが可能になります
なお、DVD-RAMには直接バックアップすることは可能です


  バックアップ結果をメールで受信することはできますか？

BunLogMailというソフトを使用すると、バックアップ結果をメールで受信することができます
BunLogMailは現在のところテスト版ですが、もしよろしければ下記のURLよりダウンロードしていただきお試しください

▼BunLogMail
http://homepage3.nifty.com/nagatsuki/bunbackup/next/bunlogmail.htm

BunLogMailはテスト版のため、試用しての感想や動作状況などをお知らせいただけると助かります


  要望・不具合・質問

「BunBackup」についての要望・不具合・質問などがありましたら、下記のメール、またはホームページからご連絡ください

メール
 nagatsuki@mbk.nifty.com

ホームページ
http://homepage3.nifty.com/nagatsuki/

現在はわかりやすさを重視しているため基本的な機能しかありませんが、今後はご要望などをお聞きしながら、随時機能を増やしていく予定です
些細な要望でもかまいませんので、お気軽にご連絡ください

また、お気づきの不具合などがありましたら、些細なことでもご連絡ください


  ホームページ

最新の「BunBackup」やサポートは下記のまたはホームページから行います

http://homepage3.nifty.com/nagatsuki/


感謝

←→
  感謝

このヘルプは、textexさんが公開している「SpeedHelpPad」を使用して作成しています

▼SpeedHelpPad
 http://textexpage.s154.xrea.com/

最初HTMLヘルプを作成するのに、なかなか良いツールが見つからなかったのですが、SpeedHelpPadに出会ってからは非常に効率よくヘルプを作成することができました

このように便利なソフトをフリーで公開していただきありがとうございます


  詳細


  設定


  ファイル


  編集


  表示


  バックアップ


  機能


  環境設定


  その他の機能


←→